Tips & How-To's

Compiz Fusion on openSUSE 10.3 and Intel onboard graphics

Contrary to what most people think, it is possible to get all those effects on their Intel based onboard graphics. Now I’ve helped a few friends to get Compiz Fusion running on their Intel cards, and I was requested by them to post this tutorial, so here it goes.

First up, download the required Compiz Fusion packages via 1-click install; Here are the links:

1-Click Installer for KDE

1-Click Installer for GNOME

1-Click Installer for Compiz Manager

We’ll have make some changes to /etc/X11/xorg.conf as well.

So open the Terminal and type

kdesu kate /etc/X11/xorg.conf –> This is for KDE users

gksudo gedit /etc/X11/xorg.conf –> This is for GNOME users

Now scroll down to Section “Module” section and check if the below are present. If not, add them.

Section "Module"
Load "dri"
Load "glx"
Load "dbe"

Add these to Section “Device”

Option "XAANoOffscreenPixmaps" "true"
Option "DRI" "true"

Add these to Section “ServerLayout”

Option "AIGLX" "true"

Make sure Section “DRI” looks like this

Group "video" Mode 0660

Finally, add this to Section “Extensions”

Option "Composite" "Enable"

Next, we’ll have to modify /usr/bin/compiz-manager to ensure that Indirect Rendering is done. For that, open Terminal and type

kdesu kate /usr/bin/compiz-manager –> For KDE Users

gksudo gedit /usr/bin/compiz-manager –> For GNOME Users

Scroll down to COMPIZ_OPTIONS and add –indirect-rendering. So now, your COMPIZ_OPTIONS should look something like

COMPIZ_OPTIONS=”–indirect-rendering –sm-disable –ignore-desktop-hints ccp –replace”
Also, For GMA X3000/3100/ 965 Chipset users, Find this section

# blacklist based on the pci ids
# See http://wiki.compiz-fusion.org/Hardware/Blacklist for details
T=” 1002:5954 1002:5854 1002:5955″ # ati rs480
T=”$T 1002:4153″ # ATI Rv350
T=”$T 8086:2982 8086:2992 8086:29a2 8086:2a02 8086:2a12″ # intel 965
BLACKLIST_PCIIDS=”$T”
unset T

And Change this to

# blacklist based on the pci ids
# See http://wiki.compiz-fusion.org/Hardware/Blacklist for details
T=” 1002:5954 1002:5854 1002:5955″ # ati rs480
T=”$T 1002:4153″ # ATI Rv350
# T=”$T 8086:2982 8086:2992 8086:29a2 8086:2a02 8086:2a12″ # intel 965
BLACKLIST_PCIIDS=”$T”
unset T

That’s about enough tweaking! To launch compiz-fusion, at the terminal type

compiz-manager

21 Comments

  1. hey
    when i type the following
    kdesu kate /usr/bin/compiz-manager
    i am just getting an blank session screen……what can i do now??

  2. @Arun Are you sure you’ve installed compiz-manager? It seems you haven’t. If you get the balnk sesson screen it (generally) means that the file isn’t found and kate is creating a new file.
    Please ensure that you’ve installed the Compiz-manager via 1-click install link given above

  3. i think i have downloaded ….because i can get the compiz-fusion settings manger window and i can enable the effects i want…but i can only enable them ..i couldnt see any changes in the screen and could’nt even activate the cube..at last i got an message from crash handeler ….after that i couldnt get my display …..now i am typing this from my windows ..i dont know what to do…how can i get my GUI back???

  4. ^ You’re confusing between CompizConfig Settings Manager(ccsm) and compiz-manager. CCSM(what you have, and are trying to use) is used for enabling disabling plugins, change the key-bindings etc.
    Compiz-manager is just a script to ensure that compiz *starts* running in the first place. So again, I’d suggest installing compiz-manager. Try booting back to openSUSE. If it still crashes, reply bak. I’ll try searching for solutions

  5. I was psyched to see a page like this for my x3100 on my T61. But, tried it step by step and it didn’t work. Ended up with no window decorators and opensuse 10.3 would freeze after login (however i could still use the mouse).

    Any tips now that some time has passed?

  6. @torano
    open the Konsole and type
    kde-window-decorator

    Do the window borders reappear?

    If so, then, open Konsole.
    Then type kdesu kate /usr/bin/compiz-manager

    Next, search for USE_EMERALD=”no” and replace it by

    USE_EMERALD=”yes”. Save it, and Exit Kate. Now, type
    compiz-manager at Konsole and press Enter

  7. I assume this applies to GNOME also, since that’s what I’m using? I just replace “kde-window-decorator” with “gnome-window-decorator”?

    Thanks for the help.

    …what is Kate?

  8. @torano Since you’re using GNOME, some things you’ll have to change.

    At the Terminal type gnome-window-decorator

    If it works then at the Terminal type
    gksu gedit /usr/bin/compiz-manager
    and follow the steps mentioned above.

    Kate is a text editor, it’s equivalent is GEdit.
    Hope that helps :)

  9. when i try to run i get this error.

    /usr/bin/compiz-manager: line 81: –sm-disable: command not found
    Checking for Xgl: not present.
    Detected PCI ID for VGA: 00:02.0 Class 0300: 8086:2772 (rev 02) (prog-if 00 [VGA])
    Checking for texture_from_pixmap: not present.
    Trying again with indirect rendering:
    Checking for texture_from_pixmap: not present.
    aborting and using fallback: /opt/kde3/bin/kwin
    trying ‘/home/brainwashed/.xcompmgrrc’ as configfile

  10. hey sorry i was late in replying. my videa card is an on board intel(R) 92945G Express Chipset Family
    now i was over with this problem. i reinstalled the opensuse 10.3 and it seemed to work after i did all the steps correctly. but it worked for like 2 days. and then everytime i start compiz fusion as my Desktop manager. the system somehow crashes. it doesn’t really crash but the effects doesn’t work. and none of the windows have the regular minimize/restore/close buttons. and i can’t close any window or switch between them. when i switch to Kde desktop manager everything works just fine..

  11. oh sorry read that one when i had the first error but didn’t look up the posts on the 2nd one. worked just fine for me thank you very much. u’re the best:D

  12. I see this is an old thread but do you know how to get compiz working on Ubuntu 10.04. Thank you for any help you can offer

Leave a Reply

Your email address will not be published. Required fields are marked *