Tips & How-To's

[How-to] Fix for Ubuntu unable to shutdown with ACPI turned off due to a problem with GeForce FX 5200 and OnBoard Intel Chipset

The title might be a little long so let me explain it here. This is in relation to my post on Ubuntu hanging during boot with nVidia FX 5200. A brief history: I tried to install and boot Ubuntu (all releases till date) with my card, and ACPI settings turned on. The LiveCD boot and the boot after installation, both hang halfway. My previous solution was to  turn off ACPI in BIOS.

That solution did not allow me to shutdown my PC normally. The shutdown was an abrupt one. An abrupt shutdown is never good for a PC. I never liked it that way also. On the other hand, I had to switch acpi on and off, to wok between Windows XP and Ubuntu on my dual boot. This was getting on my nerves. There might also be many other disadvantages/problems, by running Ubuntu ith ACPI switched off.

This how-to suggested by Paulis321 in Ubuntu Forums has actually worked for me. Thanks to him, that now I am able to boot into ubuntu with acpi switched on. The how-to, however, was bettered by me thus:

  1. Turn off ACPI in BIOS. Boot into Ubuntu (preferably, after installation).
  2. Open “/etc/modprobe.d/blacklist.conf” in gedit (or any text editor) with root permissions
  3. Add line “blacklist intel_agp” anywhere on the file. Save file
  4. Reboot
  5. Turn ACPI back on, in BIOS
  6. Save and Boot

Hope this helps

One Comment

  1. Pingback: Sathya

Leave a Reply

Your email address will not be published. Required fields are marked *