News

Use MusicBrainz Picard ? Don’t update to KDE 4.4 RC (yet)

I love MusicBrainz Picard. It keeps my music collection organized, tags and renames them, and heck even fetches the cover art for (almost) all songs. Picard is just brilliant.

And the icing on the cake – its FOSS & cross platform. And it was working fine – till couple of days ago.

Eager to try out the RC of the upcoming 4.4 release of KDE, I upgraded it. Later on I got a bunch of music files from Ankit, and I set to tag ’em correctly. Double clicked Picard. Bouncy icon starts, and then – nothing. Uh-oh. Rinse, repeat, no change. Wondering what could’ve happened, I launched Konsole and passed the command And – boom.

sathya@shaman:~> picard
Traceback (most recent call last):
File “/usr/bin/picard”, line 2, in
from picard.tagger import main; main(‘/usr/share/locale’, True)
File “/usr/lib/python2.6/site-packages/picard/tagger.py”, line 21, in
from PyQt4 import QtGui, QtCore
RuntimeError: the sip module implements API v6.0 but the PyQt4.QtGui module requires API v7.0

Seems the upgrade in Qt has resulted in MusicBrainz Picard being broken :(. As of now there seems to be no solution – perhaps wait and watch till someone notices and fixes it ? Or dive into code and try to fix it myself ( mmm enticing). Anybody reading this has a solution ? Do drop a comment

5 Comments

  1. Pingback: Sathya
  2. Pingback: Sathya
  3. Erm, why’re you commenting on your own article about the article itself?

    That aside, its the new PyQt4 that’s giving you the trouble – you’d have to get a newer SIP package from your distro’s repos or build it yourself. Not a code issue, basically any PyQt using application will stop running cause the SIP API has changed between the two versions and your current PyQt requires the newer one. But funny how you got the newer PyQt in without newer SIP :s

    1. Erm, why’re you commenting on your own article about the article itself?

      Em, I’m not. The plugin ( Topsy) pulls in all tweets featuring the URL and adds them as a trackback.

      you’d have to get a newer SIP package from your distro’s repos or build it yourself.

      I see. I’ll try to grab them. Any idea what the package name might be ? IIRC I did search but couldn’t get it. Or maybe the one relevant to it.

      But funny how you got the newer PyQt in without newer SIP :s

      Yeah :-s You run on 4.4 right ?

  4. Ah, I failed to notice those tiny bubble icons next to the first two comments.

    The package is called ‘sip’ itself, at least on Ubuntu and ArchLinux and is a dependency of PyQt4.

    Basically they should be matched with each other – PyQt4 built _after_ SIP is right.

Leave a Reply

Your email address will not be published. Required fields are marked *